pkgbuild: revert rdkafka.mpatch, use therein

No longer needed, as the Archlinux package has fixed this issue by
reverting to an older (?) method for building rdkafka, which doesn't
contain the bug this patch worked around.

Reverts: dd2565ded7
Reverts: d045174374
References: 924fddef74
This commit is contained in:
Paul Stemmet 2023-04-10 19:14:09 +00:00
parent 7f61f1b7c7
commit 1bd9308f5e
Signed by: Paul Stemmet
GPG Key ID: EDEA539F594E7E75
3 changed files with 0 additions and 25 deletions

View File

@ -162,7 +162,6 @@ pkgbase = ceph
source = ceph-17.2.4-pybind-unmock-cythonize.patch
source = ceph-17.2.5-fix-iterator-depreciations.patch
source = ceph-18.0.0-mgr-sqlite-pragmas.patch
source = rdkafka.mpatch
source = ceph-17.2.5-rgw-client-boost-string-view.patch
sha512sums = 10cd3d9eb01c91c148a92f1f7d040bbd78af5bb1ab15d071d93f54b37097dc9e1268eed9e788fe32794d137f6af81abd6a2aeaee39cef44d2c45234a15cc6020
sha512sums = 4354001c1abd9a0c385ba7bd529e3638fb6660b6a88d4e49706d4ac21c81b8e829303a20fb5445730bdac18c4865efb10bc809c1cd56d743c12aa9a52e160049
@ -179,7 +178,6 @@ pkgbase = ceph
sha512sums = 781a01e622a70d56bf1948bdc0b427ffa95a86cec7dd9d26c6007a9ec024a942a8ca55f2acc3d37344862f1d6bf11cae998d8071754cd841a66bfba4ec9c58bf
sha512sums = 2a6f33791760e14543c90077bfc6bf1b6b82ee2996e80b4762eadb887a0d9a67c221b6f10832ddf780dc6abaed246a1e2ee7680c9c861c4ff70e61b752a37b36
sha512sums = b2e1f495b57f3ed65b466719faded1713d8155e10b6432b704c632501313b6a98a56461164942cf303427770be0d5efe4798572fe8490ee977bf652906166bde
sha512sums = e4703027fccdb18be4255ba087a165e2a780248d8d52f18a776ef7b50f09f312a9e9a0d5832440a19f248b508e4ed4a869c1baa4362923f93a61e9a471760178
sha512sums = 02ca1a9bf15f9cd6f474f264ba2bf66ae725bac990a7cac315dabe377c66935a7afd8117f18a1f82c78bdf9ab2c3e5a2a227f2ffc166974dd7bb99b290f1f233
pkgname = ceph

View File

@ -92,11 +92,6 @@ source=(
# backported from the upstream
'ceph-18.0.0-mgr-sqlite-pragmas.patch'
# Fix for upstream bugs in pkgconfig of rdkafka
# https://github.com/bazaah/aur-ceph/issues/11
# https://github.com/confluentinc/librdkafka/issues/4155
'rdkafka.mpatch'
# Fixes API changes to boost::beast string_view type def in 1.81
# https://github.com/boostorg/beast/issues/2594
'ceph-17.2.5-rgw-client-boost-string-view.patch'
@ -116,7 +111,6 @@ sha512sums=('10cd3d9eb01c91c148a92f1f7d040bbd78af5bb1ab15d071d93f54b37097dc9e126
'781a01e622a70d56bf1948bdc0b427ffa95a86cec7dd9d26c6007a9ec024a942a8ca55f2acc3d37344862f1d6bf11cae998d8071754cd841a66bfba4ec9c58bf'
'2a6f33791760e14543c90077bfc6bf1b6b82ee2996e80b4762eadb887a0d9a67c221b6f10832ddf780dc6abaed246a1e2ee7680c9c861c4ff70e61b752a37b36'
'b2e1f495b57f3ed65b466719faded1713d8155e10b6432b704c632501313b6a98a56461164942cf303427770be0d5efe4798572fe8490ee977bf652906166bde'
'e4703027fccdb18be4255ba087a165e2a780248d8d52f18a776ef7b50f09f312a9e9a0d5832440a19f248b508e4ed4a869c1baa4362923f93a61e9a471760178'
'02ca1a9bf15f9cd6f474f264ba2bf66ae725bac990a7cac315dabe377c66935a7afd8117f18a1f82c78bdf9ab2c3e5a2a227f2ffc166974dd7bb99b290f1f233')
# -fno-plt causes linker errors (undefined reference to internal methods)
@ -154,9 +148,6 @@ prepare() {
# disable/remove broken tests
sed -i '/add_ceph_test(smoke.sh/d' src/test/CMakeLists.txt
sed -i '/add_ceph_test(safe-to-destroy.sh/d' src/test/osd/CMakeLists.txt
mkdir -p "__pkgconfig__"
patch /usr/lib/pkgconfig/rdkafka.pc "${srcdir}/rdkafka.mpatch" -o "__pkgconfig__/rdkafka.pc"
}
build() {
@ -172,7 +163,6 @@ build() {
export CXXFLAGS+=" ${CPPFLAGS}"
export CMAKE_BUILD_TYPE='RelWithDebInfo'
export CMAKE_WARN_UNUSED_CLI=no
export PKG_CONFIG_PATH="$PWD/__pkgconfig__:$(pkg-config --variable pc_path pkg-config)"
cmake \
-B build \

View File

@ -1,13 +0,0 @@
diff --git a/rdkakfa.pc b/rdkakfa.pc
index 0069888..523aa23 100644
--- a/rdkakfa.pc
+++ b/rdkakfa.pc
@@ -6,7 +6,7 @@ libdir=${prefix}/lib
Name: librdkafka
Description: The Apache Kafka C/C++ library
Version: 2.0.2
-Requires: curl zlib libssl libsasl2 libzstd liblz4
+Requires: libcurl zlib libssl libsasl2 libzstd liblz4
Cflags: -I${includedir}
Libs: -L${libdir} -lrdkafka
Libs.private: -lpthread -lrt -ldl -lm